Google has issued some important information regarding Google Chrome’s next update. Starting October 2017, Chrome (version 62) will show a “NOT SECURE” warning when users enter text in a form on an HTTP page. This is part of a long term plan to mark all pages served over HTTP as “not secure”.

If your website already has a secure server license then no action is required. If you do not have a secure server license, or you are not sure, then please contact us with your site URL to get this sorted.